Mold in emersed setup

Plant ID help, discussion, etc.
Post Reply
feeneyjj
Posts: 8
Joined: Wed Feb 25, 2009 6:19 pm
Real Name: John Feeney
Location: Washington DC

Mold in emersed setup

Post by feeneyjj »

I am growing mainly cryptocorynes emersed in a 55 gallon hexagonal tank. Started about four months ago. The substrate, an eclectic mixture of gravel and various commercial plant substrates, is landscaped so that there is standing water in the lower areas. The surface of the water there is covered with what I presume to be some sort of mold. Gray, green, with tiny yellow spots. I'm using rainwater since my well water (in Culpeper) is very high in copper. (Same appearance mold existed in other emersed setups in DC using municipal water. Mold always returned even after thorough flushing with rainwater there.) Tank is not hermetically sealed. I have a small submersible filter under the gravel for circulation. Plants are thriving though there is mold on the leaves of the plants in those areas where the water is up to three inches deep. Ph is probably slightly below 6.

I may gradually raise the water level, transitioning the plants to submersed culture, and convert this to a fish tank at some point. Fish are easy; plants are hard.

Is there something I can safely add to this setup that will kill the mold? Seachem Equiibrium? Raising the Ph (Seachem Alkaline Buffer)? Something else?
feeneyjj
FishEggs
Posts: 153
Joined: Mon Mar 13, 2017 6:43 am
Real Name: Matt Esterly
Location: Upper Marlboro

Re: Mold in emersed setup

Post by FishEggs »

can you post pictures?
Allen
Posts: 8
Joined: Mon Apr 19, 2021 1:27 pm
Real Name: Allen Pang

Re: Mold in emersed setup

Post by Allen »

Maybe add some springtails?
User avatar
GOT MTS?
Posts: 684
Joined: Mon Mar 08, 2010 2:13 pm
Real Name: Nick K.
Location: Sterling VA

Re: Mold in emersed setup

Post by GOT MTS? »

Springtails will help but there will likely always be some mold.
Post Reply

Sponsors